Home > readwriteweb > Google Releases Compatibility Package to Address Fragmentation Issues

Google Releases Compatibility Package to Address Fragmentation Issues

March 4th, 2011 03:02 admin Leave a comment Go to comments

Yesterday, Google launched a new tool for Android developers that will help to address the fragmentation issues facing those who want to build apps for a diverse range of Android devices, including older handsets. This tool is a static library called the “Android Compatibility package,” and it’s an extension of the Fragments API (application programming interface) built into Honeycomb. Android 3.0, code-named Honeycomb, is the tablet-optimized version of the Google’s mobile operating system now powering tablets like the Motorola Xoom and Samsung Galaxy Tab 10.1, among others.

The Fragments API introduced in Honeycomb aims to make it easier for developers to extend their tablet applications to other devices, including those with different screen sizes and resolutions. It also addresses a number of pain points with Activities, says Google in a blog post from a few weeks ago, where it detailed the changes.

The new Android Compatibility package takes Honeycomb’s Fragments API and makes it available to applications running on older versions of Android. It means that apps compatible with Android 1.6 or later can use fragments to create tablet-compatible user interfaces.

Fragmentation issues have arisen on Android because of how fast Google pushes out new code. In fact, there are currently two different versions of Android out there right now: Android 2.3 (Gingerbread) for smartphones and Android 3.0 (Honeycomb) meant for tablets. Google has said that those two separate versions will be merged in a future release of Android.

Google keeps track of the distribution of the various Android versions here on its Developers site. Android 1.6, which is as far back as the new library can address, is still running on 6.3% of Android mobile devices. Android 1.5, which will now clearly be left behind, is on 3.9% of devices. Meanwhile, Android 2.1 (31.4%), Android 2.2 (57.6%) and the newest, Android 2.3 (0.8%) take up most of the pie chart below.

Chart feb2011

The Android Compatibility package is available through the SDK Updater here.

 

 

Source: Google Releases Compatibility Package to Address Fragmentation Issues

Related Articles:

  1. Google Pressured Acer/Alibaba Because of Android Compatibility Issues
  2. Android Compatibility and Fragmentation
  3. Google Targets Android Fragmentation With Updated Terms For SDK
  4. Google Fights Back Against Android Fragmentation
  5. Google Trying New Strategy to Fix Fragmentation
blog comments powered by Disqus
YOYOYOOYOYOYO